From 45989b3e282d8a90273d5034804fd80cc4425d19 Mon Sep 17 00:00:00 2001
From: Tk-Glitch <ti3nou@gmail.com>
Date: Tue, 27 Oct 2020 18:47:47 +0100
Subject: [PATCH] TkgThingy: Update for linux-tkg refactoring

Fixes https://github.com/Tk-Glitch/PKGBUILDS/issues/584

Sync
  > community-patches: Introduce linux59-tkg patches
  > linux-tkg: Add back #62 Add initial -rc support to the install.sh script. (#100)
  > linux-tkg: linux59-tkg: Add bluetooth fix for https://bugzilla.kernel.org/show_bug.cgi?id=209745
  > linux-tkg: linux59-tkg: Update bcachefs patchset
  > linux-tkg: Move back to using nproc +1 for _force_all_threads instead of nproc *2. The 5.6 issue was fixed a while ago and really slow CPUs can choke on *2 while doing interactive tasks.
  > linux-tkg: Fix profiles path
  > linux-tkg: Update readme
  > linux-tkg: Adjust community-patches path for the new unified-builder path
  > linux-tkg: Move to unified builder as default
  > linux-tkg: unified-builder: Update readme
  > linux-tkg: unified-builder: Minor adjustments
  > linux-tkg: unified builder: Add LTS and RC to the version selector
  > linux-tkg: unified-builder: linux59/510-tkg: Update prjc patchset to v5.9-r1 + hotfix https://gitlab.com/alfredchen/linux-prjc/-/commit/c6e352a26de8e46f5737fed2b876516df82adad1
  > linux-tkg: unified builder: Small maintenance-friendly tweaks and added support for 5.10rc1
  > linux-tkg: cosmetics in localversion if using llvm (#95)
  > linux-tkg: linux59/510-tkg: Fix compilation with MuQSS on Debian-based distros
  > linux-tkg: Update readmes
  > linux-tkg: linux510-rc-tkg: Add CONFIG_USER_NS_UNPRIVILEGED to defconfig
  > nvidia-all: Add initial kernel 5.10 support patch
  > wine-tkg-git: Require staging for proton-rawinput-nofshack checks
---
 TkgThingy         | 57 ++++++++---------------------------------------
 community-patches |  2 +-
 linux-tkg         |  2 +-
 nvidia-all        |  2 +-
 wine-tkg-git      |  2 +-
 5 files changed, 13 insertions(+), 52 deletions(-)

diff --git a/TkgThingy b/TkgThingy
index a72b8d9..ebc45e8 100755
--- a/TkgThingy
+++ b/TkgThingy
@@ -32,39 +32,12 @@ _external_cfg() {
         _cfg_loop
     fi
 
-    # linux54-tkg
-    if [ "$linux54_tkg" == "true" ]; then
-        _config_file_path=linux-tkg/linux54-tkg
+    # linux-tkg
+    if [ "$linux_tkg" == "true" ]; then
+        _config_file_path=linux-tkg
         _config_file_basename=customization.cfg
-        _config_file_targname=linux54-tkg.cfg
-        unset linux54_tkg
-        _cfg_loop
-    fi
-
-    # linux57-tkg
-    if [ "$linux57_tkg" == "true" ]; then
-        _config_file_path=linux-tkg/linux57-tkg
-        _config_file_basename=customization.cfg
-        _config_file_targname=linux57-tkg.cfg
-        unset linux57_tkg
-        _cfg_loop
-    fi
-
-    # linux58-tkg
-    if [ "$linux58_tkg" == "true" ]; then
-        _config_file_path=linux-tkg/linux58-tkg
-        _config_file_basename=customization.cfg
-        _config_file_targname=linux58-tkg.cfg
-        unset linux58_tkg
-        _cfg_loop
-    fi
-
-    # linux59-tkg
-    if [ "$linux59_tkg" == "true" ]; then
-        _config_file_path=linux-tkg/linux59-tkg
-        _config_file_basename=customization.cfg
-        _config_file_targname=linux59-tkg.cfg
-        unset linux59_tkg
+        _config_file_targname=linux-tkg.cfg
+        unset linux_tkg
         _cfg_loop
     fi
 
@@ -147,16 +120,13 @@ _main_loop() {
     else
         mkdir -p "$_EXT_CONFIG_PATH"
         echo -e "\nPlease select which tool you want to create external config files for (or all of them with option #1) :"
-        select tkg_tools in "all" "dxvk_tools" "gamescope" "linux54_tkg" "linux57_tkg" "linux58_tkg" "linux59_tkg" "mesa_git" "mostlyportable_gcc" "mostlyportable_mingw" "nvidia_all" "vkd3d_git" "proton_tkg" "wine_tkg"
+        select tkg_tools in "all" "dxvk_tools" "gamescope" "linux_tkg" "mesa_git" "mostlyportable_gcc" "mostlyportable_mingw" "nvidia_all" "vkd3d_git" "proton_tkg" "wine_tkg"
         do
             case $tkg_tools in
                 "all")
                     dxvk_tools="true"
                     gamescope="true"
-                    linux54_tkg="true"
-                    linux56_tkg="true"
-                    linux57_tkg="true"
-                    linux58_rc_tkg="true"
+                    linux_tkg="true"
                     mesa_git="true"
                     mostlyportable_gcc="true"
                     mostlyportable_mingw="true"
@@ -171,17 +141,8 @@ _main_loop() {
                 "gamescope")
                     gamescope="true"
                     ;;
-                "linux54_tkg")
-                    linux54_tkg="true"
-                    ;;
-                "linux57_tkg")
-                    linux57_rc_tkg="true"
-                    ;;
-                "linux58_tkg")
-                    linux58_tkg="true"
-                    ;;
-                "linux59_tkg")
-                    linux59_tkg="true"
+                "linux_tkg")
+                    linux_tkg="true"
                     ;;
                 "mesa_git")
                     mesa_git="true"
diff --git a/community-patches b/community-patches
index 2b4be36..773ecfd 160000
--- a/community-patches
+++ b/community-patches
@@ -1 +1 @@
-Subproject commit 2b4be36bf4dc4588cbc53c2c2044906635d151fa
+Subproject commit 773ecfdf8d66c7854a43721b434bc01db6686769
diff --git a/linux-tkg b/linux-tkg
index d84bb61..191febe 160000
--- a/linux-tkg
+++ b/linux-tkg
@@ -1 +1 @@
-Subproject commit d84bb61760c52bdcfdb302a60c586019b435027c
+Subproject commit 191febe4e8acf1ff1d1f680cd2b532ae09462402
diff --git a/nvidia-all b/nvidia-all
index f1d3c6c..62d60fe 160000
--- a/nvidia-all
+++ b/nvidia-all
@@ -1 +1 @@
-Subproject commit f1d3c6cf024945e7a477ed306bd173fa6b81d72d
+Subproject commit 62d60fea19fe6c0a1d90d04a2653fb198d3f214c
diff --git a/wine-tkg-git b/wine-tkg-git
index ab18cc0..bcf4f94 160000
--- a/wine-tkg-git
+++ b/wine-tkg-git
@@ -1 +1 @@
-Subproject commit ab18cc0f97ad84517986358483e767b292a27890
+Subproject commit bcf4f949bc9b3c53d517abf767e2361e1d4b1436